We are continuing to work on improvements to our Google Ads Search data retrieval. Our team is focused on implementing a new system that will be more robust and reliable. This system is currently in testing, and we're simulating high-traffic scenarios to ensure a smooth transition when it's fully launched.
In the meantime, we've made some progress in expanding our support for mobile devices. We've begun rolling out support for Android, and you may start seeing ads appear in your Android searches. This is still in an experimental phase, so please bear with us as we continue to refine it.
We are aware that ads data on iOS devices is still not consistently appearing. We are actively investigating solutions to address this and will provide further updates as we make progress.
Posted Jan 25, 2025 - 02:50 GMT
Update
Following the recent changes on the Google platform related to Ads search data, we've been working to improve how we retrieve and process data to ensure its accuracy and reliability. We are working through deploying a new system that leverages headless Chrome technology and enhancements to our API server. We're currently conducting extensive testing, simulating high-traffic scenarios to guarantee a smooth transition and avoid any disruption to your workflows. We anticipate these improvements will lead to more reliable data retrieval and an overall better experience for our users. We'll continue to provide updates as we move towards the full rollout.
Posted Jan 22, 2025 - 20:35 GMT
Identified
Our team is making meaningful progress in adapting to recent changes on the Google Ads platform. These changes require us to update how we retrieve and process Google Ads data to ensure its accuracy and reliability. Our team has identified a solution and is now focused on refining it for stability and consistency. This involves optimizing data retrieval processes, making infrastructure adjustments, and conducting rigorous testing to avoid any disruption to your workflows. We understand that consistent access to your Google Ads data is critical, and we're committed to providing updates as we work towards a smooth transition.