We’re excited to share that Google search functionality is back up and running!
We understand how critical this service is for your operations, and our team has been working diligently to restore it as quickly as possible.
Thank you for your patience and partnership.
Posted Jan 17, 2025 - 22:34 GMT
Update
We have made progress in restoring functionality, with a portion of our infrastructure now operating under the new approach. That said, access to Google Search remains limited, and success rates are not yet at expected levels.
To ensure consistent, reliable, and accurate data, we are taking a measured approach. Deploying changes too quickly without proper validation could introduce instability, lead to inconsistent results, or cause further disruptions.
Our team is actively working to: - Expand deployment in a controlled manner to steadily improve access while maintaining stability. - Restore performance levels to align with customer expectations as efficiently as possible. - Proactively monitoring for further changes to adapt swiftly if needed.
We are making significant progress in refining our approach and expect continued improvements as we move forward. We recognize the challenges this situation is causing for your organization and deeply appreciate your understanding and patience as we work diligently to restore full functionality.
Posted Jan 17, 2025 - 12:46 GMT
Update
We are continuing to aggressively work on a solution to the ongoing issue affecting our Web Search SERP services. As can be the case with large-scale web extraction services, site owner/operators occasionally deploy services that can limit or halt the ability to extract the expected data. Our team is diligently working to address these changes and restore full functionality as quickly as possible.
Posted Jan 16, 2025 - 20:32 GMT
Identified
Our technical teams believe they have identified the source of the issue impacting our Web Search SERP services and are working on implementing a solution to restore full functionality. We will continue to provide updates as we make progress.
Posted Jan 16, 2025 - 17:24 GMT
Investigating
We are actively addressing a service disruption that is impacting a set of our Web Search SERP services. At present, data requests for non-Web Search (e.g. News, Shopping, etc..) are working as expected. We are committed to resolving this issue and restoring optimal performance as quickly as possible.